bexio is impaired or may not be available

Incident Report for bexio AG

Resolved

bexio is fully operational again. We apologize for the inconvenience.
Posted Dec 18, 2025 - 16:09 CET

Identified

bexio is currently impaired or may not be available. Our technicians are already working on a solution with priority.
Posted Dec 18, 2025 - 15:40 CET
This incident affected: bexio Office.