bexio impaired

Incident Report for bexio AG

Resolved

We were able to resolve the issue with one of our network providers.
bexio is now available again with its usual reliability and speed.
We thank you for your understanding and apologise for any inconvenience caused.
Posted Nov 20, 2025 - 21:03 CET

Investigating

We are actively investigating a situation where bexio is not working as expected. bexio may not be available to you or return failures.

Thank you for your patience while we are working towards a solution! The status page will be updated with more information as it becomes available.
Posted Nov 20, 2025 - 08:34 CET
This incident affected: bexio Office.