bexio support not available
Incident Report for bexio AG
Resolved
This incident has been resolved.
Posted Oct 27, 2023 - 17:09 CEST
Update
We are continuing to investigate this issue.
Posted Oct 27, 2023 - 14:44 CEST
Investigating
The bexio support is currently unavailable due to technical issues. Please contact via Guuru Chat or mail to support@bexio.com and we will assist you as soon as possible.
Posted Oct 27, 2023 - 14:20 CEST
This incident affected: bexio Website.