Processing of banking transactions and contacts import delayed

Incident Report for bexio AG

Resolved

Bank transactions have been successfully processed and imported. Contact imports are also available again. You can now use bexio as usual. Thank you for your patience.
Posted Mar 17, 2026 - 13:02 CET

Identified

Bank transactions are currently experiencing delays in importing and processing. You may also notice a delay with contact imports. We are already working on a fix to ensure bexio is fully available to you as soon as possible. Thank you for your patience.
Posted Mar 17, 2026 - 10:12 CET
This incident affected: bexio Office and Banking / Fetch transactions.