Limited email delivery - resolved

Incident Report for bexio AG

Resolved

The situation has been resolved and you are able to continue using bexio as usual.

We sincerely apologize for any inconvenience.
Posted Jan 21, 2025 - 16:00 CET

Investigating

We are currently investigating problems with sending emails. These are not being sent and remain in the queue.
Thank you for your patience while we work on a solution! The status page will be updated with further information as it becomes available.
Posted Jan 21, 2025 - 10:19 CET
This incident affected: bexio application.