bexio 071 552 00 60/61/62 nicht erreichbar - 071 552 00 60/61/62 not reachable

Incident Report for bexio AG

Resolved

This incident has been resolved.
Posted Nov 16, 2022 - 14:56 CET

Investigating

bexio Support is currently not reachable by phone. Our phone provider is currently experiencing issues, we will inform you once we are reachable again.
Posted Nov 16, 2022 - 14:15 CET