Telephone provider outage

Incident Report for bexio AG

Resolved

Issue resolved
Posted Jan 19, 2026 - 10:33 CET

Investigating

Due to a disruption with our external telephone provider, our support team is currently only available in writing. Please use our contact form (https://help.bexio.com/s/contact-support?language=en_US) or the expert chat for your inquiry.
Posted Jan 19, 2026 - 08:55 CET