bexio unavailable

Incident Report for bexio AG

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 09:47 CEST

Investigating

The module “Payroll” is currently impaired or may not be available. Our technicians are already working on a solution with priority.
Posted Oct 22, 2025 - 09:21 CEST
This incident affected: Payroll.